Een buffer overflow in Macromedia’s Java 2 Enterprise Edition (kortweg J2EE) zorgt ervoor dat een hacker de server volledig kan overnemen, aldus Next Generation Security Software. Het lek zit in Jrun 3.1 dat draait onder Microsoft Internet Information Services (IIS) Server versie 4.0, 5.0 of Windows NT 4 en Windows 2000. Het bedrijf heeft Macromedia al in april gewaarschuwd. Macromedia heeft sindsdien een nieuwe versie uitgebracht die het let in de software dicht.