In de laatste versie van het vlaggenschip van Novell zit een bug die voor problemen kan zorgen in netwerken waarop nieuwe en oude versies van de serversoftware draaien. Het mankement kan bestaande directory-bestanden in de war schoppen. De jongste versie van Novell Directory Services (NDS), die onderdeel uitmaakt van NetWare 5, bevat schema-extensies die door servers met NetWare 4.1 en hoger niet worden begrepen. Novell heeft het probleem in een vroeg stadium onderkend. Het bedrijf kwam een tijdje geleden al met een oplossing met het advies om de oude servers te voorzien van de nieuwste versie van NDS voordat NetWare 5 op een bestaand netwerk wordt geïntroduceerd. De huidige versie van NDS, 5.99a, is al een tijdje beschikbaar als update – nog voordat de nieuwste NetWare op de buitenwereld werd losgelaten. Recent heeft Novell echter ontdekt dat de eerste oplossing toch nog tot verlies aan data kan leiden als oude en nieuwe versies van de directory services door elkaar worden gebruikt en er tegelijkertijd een schema-update en directory-synchronisatie plaatsvind. Voor dat laatste euvel werkt Novell nog aan een fix. Intussen heeft het bedrijf een bèta (versie 6.0) van NDS klaargestoomd. Deze wordt nu uitgebreid getest. De update is pas officieel als zeker honderd gebruikers de software hebben gedownload en hebben getest.