Doordat IE 7 erg veilig moet zijn, maakt de browser gebruik van de veiligheidstechnieken van Windows XP. Hierdoor kunnen gebruikers van oudere versies van Windows de browser niet gebruiken. Dit hebben de ontwikkkelaars bekendgemaakt op het weblog van Internet Explorer.

Critici klagen dat de browser mensen dwingt over te stappen naar Windows XP, terwijl de opvolger Longhorn in 2006/2007 gepland staat. Gebruikers van Windows 2000 en oudere Windows-versies worden overigens niet verplicht over te stappen, aangezien er vele alternatieven voor handen zijn, zoals Firefox en Opera.