De updates krijgen versienummer 7.6.7 en 7.7.7 mee en zijn bedoeld voor de AirPort Express, AirPort Extreme en AirPort Time Capsule base stations. Dit geldt zowel voor de versies die werken met het 802.11n- als het 802.11ac-Wifi-protocol.

Gebruikers kunnen AirPort Utility 6.3.1 of hoger op OS X gebruiken om de apparaten te updaten of versie 1.3.1 of nieuwer als er met iOS gewerkt wordt.

Apple heeft verder geen details gegeven over de lekken en er wordt niets verteld over de mogelijkheden waarop deze kwetsbaarheid kan worden misbruikt. Het enige dat duidelijk wordt uit de aankondiging is dat de kwetsbaarheid zit in de code die zich bezighoudt met het parsen van DNS-adressen.