Na recente patches van grote beveiligingsfouten in Flash heeft Apple via een update vrijdag de kwetsbare Flash-versies geblokkeerd. Gebruikers moeten updaten naar de laatste versie als ze Flash willen blijven gebruiken. Apple gebruikt hiervoor zijn Xprotect-malwarescanner die in Mac OS X is ingebouwd.

Eerder deze week heeft Adobe een update uitgebracht die drie kwetsbaarheden in Flash patchte. Twee daarvan waren gericht op Mozilla's Firefox-browser.

Java-lek

In januari blokkeerde Apple ook al Java op alle Macs op een vergelijkbare manier, in afwachting van een update van Oracle.