Het Samba Team, de groep die de open-sourcesoftware beheert, heeft inmiddels een patch ontwikkeld. Ook is een nieuwe versie, Samba 2.2.8a, geïntroduceerd die het lek dicht. Samba werkt op diverse besturingssystemen - waaronder Linux, Unix, OpenVMS en OS/2 – en is een veelgebruikt softwarepakket voor wederzijdse toegang tot de bestandssystemen van Linux en Windows. Het beveiligingslek is ontdekt door Digital Defense. Het beveiligingsbureau zegt inmiddels al een programma te hebben ontdekt dat het lek misbruikt. Overigens gaat Digital Defense hier niet helemaal vrij. Het bedrijf heeft namelijk per ongeluk zijn eigen exploit, een programma om een lek te misbruiken, online gezet Digital Defense adviseert gebruikers van Samba in ieder geval de nieuwste versie te installeren. Deze is te downloaden vanaf de Samba-website.