Het is niet de eerste keer dat een groep applicaties niet langer compatible is met het besturingssysteem van Apple. Toen het bedrijf stopte met het meeleveren van Rosetta in Mac OS X 10.7 Lion, moesten gebruikers een aantal applicaties opnieuw aanschaffen of upgraden. Rosetta werd destijds gebruikt om legacy-apps te kunnen draaien op een Intel-processor. Deze ondersteuning werd niet langer meegeleverd met Lion.

Apple stopt nu met de ondersteuning met 32-bit apps in High Sierra wat betekent dat gebruikers zo snel mogelijk moeten switchen naar 64-bit-exemplaren als deze bestaan. Toch zal Apple niet direct de volledige ondersteuning laten vallen. Sommige 32-bit-apps worden nog deels ondersteund, maar Apple zegt wel dat alle apps in de Mac App Store 64-bit moeten zijn vanaf januari 2018.

De volgende versie van macOS zal helemaal geen 32-bit-software meer ondersteunen dus voor die tijd zullen softwarebouwers alles overgezet moeten hebben.

Wij hebben gekeken welke (oudere/32-bit applicaties) er nog wel werken op het systeem.

Apple apps die niet werken in High Sierra

Apple levert al tijden verschillende apps mee met het besturingssysteem waaronder Final Cut Studio en Logic Studio. Inmiddels zijn beide apps al lang en breed vervangen door Final Cut Pro X en Logic Pro X, maar als je de oudere versies nog gebruikt, is het nu toch echt tijd om afscheid te nemen van deze programma's. Dit geldt ook voor DVD Studio Pro, Soundtrack Pro, Colour Cinema Tools en alle andere gebundelde tools en apps.

Als je inmiddels de nieuwere X-versies gebruikt, controleer dan of je de nieuwste versies draait. Oudere versies werken niet of nauwelijks in High Sierra. Je moet minimaal de volgende versies hebben:


Microsoft apps

Microsoft heeft aangekondigd Office 2011-apps niet langer "formeel te ondersteunen" in High Sierra. Officiële ondersteuning stopt sowieso op 10 oktober. Gebruikers die Office 2016 draaien zullen moeten upgraden naar versie 15.35.

De nieuwste versie van Office kan hier worden gedownload.

Adobe apps

Adobe waarschuwt dat 2017 releases van Illustrator en ouder niet zijn ontworpen voor High Sierra en ook niet worden ondersteund door Adobe.

Gebruikers die nog met CS4 werken zullen tegen verschillende problemen aanlopen en zullen het pakket hier moeten bijwerken.

Andere apps

Wij hebben verschillende apps gecheckt met de High Sierra beta en de volgende veelgebruikte populaire apps gaven problemen:

  • Autodesk AutoCAD 2017
  • Civilization V
  • CodeWeavers CrossOver (en alle programma's die gebruik maken van deze software waaronder LogMeIn Rescue).
  • DiskWarrior 5.0
  • Sophos AV

Via deze lijst kan je kijken of jouw software compatible is met het nieuwe besturingssysteem van Apple.

32-bit-apps controleren

De volgende versie van Apple's besturingssysteem zal helemaal niet meer overweg kunnen met 32-bit-apps. Gelukkig kan je nu alvast controleren welke software op je systeem nog 32-bit is en tijdig actie ondernemen. Dat kan je doen door te navigeren naar het Apple-menu, te klikken op "Over deze Mac" en "Systeeminformatie" te kiezen. Vervolgens klik je op Software en kies je Applicaties. In de laatste kolom kan je zien welke applicaties er 64-bit zijn.

Van alle applicaties dier er nog op ons testsysteem stonden waren de volgende programma's nog 32-bit:

  • Adobe Illustrator CS5
  • Adobe InDesign CS5
  • Microsoft Excel 2011
  • Microsoft PowerPoint 2011
  • Microsoft Outlook 2011
  • Microsoft World 2011