Vier van de lekken worden door Mozilla aangeduid als gemiddelde dreiging, en twee als lage dreiging.

Een van de kritische dreigingen hield in dat iemand van buiten XPCNativeWrapper met een Javascript zo kan beïnvloeden dat iemand van buiten in de Browser Chrome dezelfde rechten krijgt als de gebruiker. Een vergelijkbaar lek werd in versie 2.0.0.5 ook al gedicht.

De dreiging die Mozilla als kritisch bestempelt is dat de browser kan crashen, waarbij het in sommige gevallen mogelijk is om arbitrary code uit te voeren. Dit probleem kan ook voor emailprogramma Thunderbird gelden.

De nieuwe versie van Firefox is compatibel met Mac OS X 10.5, al melden de makers dat daar nog wat problemen zijn. Opera heeft deze week ook zijn browser geupdate, naar 9.5 Alpha. Bron: Techworld