Kodi heeft altijd met Python 2 als interpreter gewerkt voor add-ons en plug-ins, maar aangezien deze versie van Python vanaf 1 januari 2020 end of life is, heeft het team achter Kodi besloten te switchen naar Python 3. Dit zorgt er echter wel voor dat sommige plug-ins niet meer zullen werken aangezien niet alle functies van Python 2 compatibel zijn met Python 3. Ontwikkelaars zullen dus aan de slag moeten om hun plug-ins en add-ons om te zetten naar Python 3. Helaas is er ook een aantal plug-ins waar niet of nauwelijks meer aan gewerkt  die tussen wal en schip vallen.

Het ontwikkelingsteam achter Kodi wil dat voorkomen door de gemeenschap te betrekken bij het proces om inactieve add-ons beschikbaar voor Kodi 19 te maken. Gebruikers kunnen add-ons rapporteren die momenteel niet werken met Kodi 19 en ontwikkelaars met Python-vaardigheden worden aangemoedigd om deze add-ons gereed te maken voor de nieuwe release.


Gebruikers die de nieuwe versie van Kodi willen testen, kunnen de nightly build hier downloaden.